Announcement-ID: PMASA-2020-4

Date: 2020-03-20

Updated: 2020-03-22


SQL injection relating to data display


An SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results.

The attack requires an attacker be able to insert specially-crafted data in to certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.


We consider this flaw to be of moderate severity.

Affected Versions

phpMyAdmin 4.9.x releases prior to 4.9.5 and the 5.0.x releases prior to 5.0.2 are affected. We believe the flaw was introduced with phpMyAdmin 3.4.


Upgrade to phpMyAdmin 4.9.5 or 5.0.2 or newer or apply patch listed below.


Thanks to Yutaka WATANABE for reporting this vulnerability.

Assigned CVE ids: CVE-2020-10803

CWE ids: CWE-661


The following commits have been made to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is