Multiple XSS vulnerabilities.
We consider these vulnerabilities to be non-critical.
These vulnerabilities can be triggered only by someone who is logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required pages.
Versions 4.0.x (prior to 126.96.36.199), 4.4.x (prior to 188.8.131.52) and 4.5.x (prior to 4.5.4) are affected.
Upgrade to phpMyAdmin 184.108.40.206 or newer, 220.127.116.11 or newer, 4.5.4 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting these vulnerabilities.
Assigned CVE ids: CVE-2016-2040
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.5 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.