DOS attack with forced persistent connections
A vulnerability was discovered where an unauthenticated user is able to execute a denial-of-service (DOS) attack by forcing persistent connections when phpMyAdmin is running with
We consider this vulnerability to be critical, although note that phpMyAdmin is not vulnerable by default.
This attack requires phpMyAdmin to be configured with`$cfg['AllowArbitraryServer']=true;`
All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 126.96.36.199), and 4.0.x versions (prior to 188.8.131.52) are affected.
Upgrade to phpMyAdmin 4.6.4, 184.108.40.206, or 220.127.116.11 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-6622
CWE ids: CWE-661
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.6 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.