PMASA-2019-2

Announcement-ID: PMASA-2019-2

Date: 2019-01-22

Summary

SQL injection in Designer feature

Description

A vulnerability was reported where a specially crafted username can be used to trigger an SQL injection attack through the designer feature.

Severity

We consider this vulnerability to be serious.

Affected Versions

phpMyAdmin versions from 4.5.0 through 4.8.4 are affected

Solution

Upgrade to phpMyAdmin 4.8.5 or newer or apply patch listed below.

References

Thanks to YU-HSIANG HUANG (huang.yuhsiang.phone@gmail.com), YUNG-HAO TSENG, and Eddie TC CHANG for reporting this vulnerability.

Assigned CVE ids: 2019-6798

CWE ids: CWE-661 CWE-89

Patches

The following commits have been made to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.

Announcements