Remote code execution vulnerability when PHP is running with dbase extension
A vulnerability was discovered where phpMyAdmin can be used to trigger a remote code execution attack against certain PHP installations.
We consider this vulnerability to be critical.
This vulnerability only exists when PHP is running with the dbase extension, which is not shipped by default, not available in most Linux distributions, and doesn't compile with PHP7.
All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 22.214.171.124), and 4.0.x versions (prior to 126.96.36.199) are affected
Upgrade to phpMyAdmin 4.6.4, 188.8.131.52, 184.108.40.206, or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-6633
CWE ids: CWE-661
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.6 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.