Announcement-ID: PMASA-2014-16

Date: 2014-11-20


Leakage of line count of an arbitrary file.


In the error reporting feature, a parameter specifying the file was not correctly validated, allowing the attacker to derive the line count of an arbitrary file.


We consider this vulnerability to be non critical.

Mitigation factor

This vulnerability can be triggered only by someone who is logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required page.

Affected Versions

Versions 4.1.x (prior to and 4.2.x (prior to 4.2.12) are affected.


Upgrade to phpMyAdmin or newer, or 4.2.12 or newer, or apply the patch listed below.


Thanks to Johannes Dahse ( for reporting this vulnerability.

Assigned CVE ids: CVE-2014-8961

CWE ids: CWE-661 CWE-23


The following commits have been made to fix this issue:

The following commits have been made on the 4.1 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is