Vulnerability allowing man-in-the-middle attack on API call to GitHub.
A vulnerability in the API call to GitHub can be exploited to perform a man-in-the-middle attack.
We consider this vulnerability to be serious.
Versions 4.0.x (prior to 22.214.171.124), 4.2.x (prior to 126.96.36.199), 4.3.x (prior to 188.8.131.52) and 4.4.x (prior to 184.108.40.206) are affected.
Upgrade to phpMyAdmin 220.127.116.11 or newer, or 18.104.22.168 or newer, or 22.214.171.124 or newer, or 126.96.36.199 or newer, or apply the patch listed below.
Thanks to Maksymilian Arciemowicz of http://cxsecurity.com for reporting this vulnerability.
Assigned CVE ids: CVE-2015-3903
The following commits have been made to fix this issue:
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.2 branch to fix this issue:
The following commits have been made on the 4.3 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.