PMASA-2017-6

Announcement-ID: PMASA-2017-6

Date: 2017-01-24

Summary

SSRF in replication

Description

For a user with appropriate MySQL privileges it was possible to connect to arbitrary host.

Severity

We consider this to be non-critical.

Mitigation factor

The vulnerability is exposed only to MySQL superusers.

Affected Versions

All 4.6.x versions (prior to 4.6.6), 4.4.x versions (prior to 4.4.15.10), and 4.0.x versions (prior to 4.0.10.19) are affected.

Solution

Upgrade to phpMyAdmin 4.6.6, 4.4.15.10, or 4.0.10.19 or newer or apply patch listed below.

References

Thanks to butian_235 for reporting this vulnerability.

Assigned CVE ids: Not yet assigned

CWE ids: CWE-661

Patches

The following commits have been made on the 4.0 branch to fix this issue:

The following commits have been made on the 4.4 branch to fix this issue:

The following commits have been made on the 4.6 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.

Announcements