Unsafe usage of unserialize function.
phpMyAdmin used the unserialize() PHP function on potentially unsafe data in setup script, what could be potentially used for XSRF attack, which can lead to code execution.
We consider these vulnerabilities to be critical.
For 2.11.x: versions before 2.11.10 are affected.
3.x releases are not affected.
Upgrade to phpMyAdmin 3.0.0 or 2.11.10.
We wish to thank to Thomas Biege and Sebastian Krahmer for pointing out this issue.
Assigned CVE ids: CVE-2009-4605
The following commits have been made on the 2.11 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.