XSRF/CSRF vulnerability in phpMyAdmin setup.
By deceiving a user to click on a crafted URL, it is possible to alter the configuration file being generated with phpMyAdmin setup.
We consider this vulnerability to be non critical.
This vulnerability only affects the configuration file generation process and does not affect the effective configuration file. Moreover, the configuration file being generated is at risk only during the period when it's writable.
Versions 4.0.x (prior to 184.108.40.206), 4.2.x (prior to 220.127.116.11), 4.3.x (prior to 18.104.22.168) and 4.4.x (prior to 22.214.171.124) are affected.
Upgrade to phpMyAdmin 126.96.36.199 or newer, or 188.8.131.52 or newer, or 184.108.40.206 or newer, or 220.127.116.11 or newer, or apply the patch listed below.
Thanks to Inti De Ceukelaire (http://ceukelai.re) for reporting this vulnerability.
Assigned CVE ids: CVE-2015-3902
The following commits have been made to fix this issue:
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.2 branch to fix this issue:
The following commits have been made on the 4.3 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.