Remote code execution vulnerability when run as CGI
A vulnerability was discovered where a user can execute a remote code execution attack against a server when phpMyAdmin is being run as a CGI application. Under certain server configurations, a user can pass a query string which is executed as a command-line argument by the file
We consider this vulnerability to be critical.
The file `/libraries/plugins/transformations/generator_plugin.sh` may be removed. Under certain server configurations, it may be sufficient to remove execute permissions for this file.
All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 188.8.131.52), and 4.0.x versions (prior to 184.108.40.206) are affected
Upgrade to phpMyAdmin 4.6.4, 220.127.116.11, 18.104.22.168, or newer, or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-6631
CWE ids: CWE-661
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.6 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.