XSS through FPD
With a specially crafted request, it is possible to trigger an XSS attack through the example OpenID authentication script.
We do not consider this vulnerability to be secure due to the non-standard required PHP setting for html_errors.
The attack requires html_errors = Off in php.ini, so it can be mitigated by setting html_errors = On. As an alternative mitigation means, the ./examples/openid.php file can be removed.
All 4.6.x versions (prior to 4.6.3), 4.4.x versions (prior to 184.108.40.206), and 4.0.x versions (prior to 220.127.116.11) are affected
Upgrade to phpMyAdmin 4.6.3, 18.104.22.168, or 22.214.171.124 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-5731
CWE ids: CWE-661
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.6 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.