Multiple full path disclosure vulnerabilities.
By calling some scripts that are part of phpMyAdmin in an unexpected way, it is possible to trigger phpMyAdmin to display a PHP error message which contains the full path of the directory where phpMyAdmin is installed.
We consider these vulnerabilities to be non-critical.
This path disclosure is possible on servers where the recommended setting of the PHP configuration directive display_errors is set to on, which is against the recommendations given in the PHP manual for a production server.
Versions 4.0.x (prior to 22.214.171.124), 4.4.x (prior to 126.96.36.199) and 4.5.x (prior to 4.5.4) are affected.
Upgrade to phpMyAdmin 188.8.131.52 or newer, 184.108.40.206 or newer, 4.5.4 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting these vulnerabilities.
Assigned CVE ids: CVE-2016-2038
The following commits have been made on the 4.0 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.5 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.