Bringing MySQL to the web


Announcement-ID: PMASA-2013-7

Date: 2013-06-30

Updated: 2013-07-01


Global variable scope injection.


The import.php script was vulnerable to GLOBALS variable injection. Therefore, an attacker could manipulate any configuration parameter.


We consider this vulnerability to be serious.

Mitigation factor

This vulnerability can be triggered only by someone who logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required form.

Affected Versions

Versions 4.0.x up to 4.0.4 are affected.

Unaffected Versions

Versions prior to 4.0.0 are not affected.


Upgrade to phpMyAdmin or newer, or apply the patch listed below.


Thanks to Markus Wulftange of Daimler TSS for reporting this issue.

Assigned CVE ids: CVE-2013-4729

CWE ids: CWE-621 CWE-661


The following commits have been made to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is