Global variable scope injection.
The import.php script was vulnerable to GLOBALS variable injection. Therefore, an attacker could manipulate any configuration parameter.
We consider this vulnerability to be serious.
This vulnerability can be triggered only by someone who logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required form.
Versions 4.0.x up to 4.0.4 are affected.
Versions prior to 4.0.0 are not affected.
Upgrade to phpMyAdmin 184.108.40.206 or newer, or apply the patch listed below.
Thanks to Markus Wulftange of Daimler TSS for reporting this issue.
Assigned CVE ids: CVE-2013-4729
The following commits have been made to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.