A vulnerability was reported with the
$cfg['ArbitraryServerRegexp'] configuration directive. An attacker could reuse certain cookie values in a way of bypassing the servers defined by
We consider this vulnerability to be critical.
Only servers using `$cfg['ArbitraryServerRegexp']` are vulnerable to this attack.
All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 188.8.131.52), and 4.0.x versions (prior to 184.108.40.206) are affected
Upgrade to phpMyAdmin 4.6.4, 220.127.116.11, 18.104.22.168, or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-6629
CWE ids: CWE-661
The following commits have been made on the 4.6 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.0 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.