Multiple vulnerabilities in setup script
A server-side request forgery vulnerability was reported with the setup script. This flaw can allow an unauthenticated attacker to:
Additionally there was a race condition between writing configuration and administrator moving it allowing unauthenticated users to read or alter it.
We consider this vulnerability to be critical.
Removal of setup directory after initial setup as described in our documentation avoids this problem.
All 4.6.x versions (prior to 4.6.6), 4.4.x versions (prior to 22.214.171.124), and 4.0.x versions (prior to 126.96.36.199) are affected
Upgrade to phpMyAdmin 4.6.6, 188.8.131.52, or 184.108.40.206 or newer or apply patch listed below.
Thanks to Emanuel Bronshtein @e3amn2l for reporting this vulnerability.
Assigned CVE ids: CVE-2016-6621
CWE ids: CWE-661
The following commits have been made on the 4.6 branch to fix this issue:
The following commits have been made on the 4.4 branch to fix this issue:
The following commits have been made on the 4.0 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.