XSS attack in database search.
It was possible to conduct a XSS attack using spoofed request on the db search script.
We consider this vulnerability to be non critical.
For 3.x: versions before 22.214.171.124 are affected. For 2.11.x: versions before 126.96.36.199 are affected.
Upgrade to phpMyAdmin 188.8.131.52 or newer, or 184.108.40.206 if using the 2.11.x family. You can also apply the patch listed below.
Thanks to Alexander Opitz for reporting this issue.
Assigned CVE ids: CVE-2010-4329
The following commits have been made to fix this issue:
The following commits have been made on the 2.11 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.