Bringing MySQL to the web


Announcement-ID: PMASA-2011-12

Date: 2011-07-23

Updated: 2011-07-25


Possible superglobal and local variables manipulation in swekey authentication.


It was possible to manipulate the PHP superglobals (including SESSION) using some of the Swekey authentication code. Also, variables local to the affected Swekey function were at risk. This is similar to PMASA-2011-5.


We consider this vulnerability to be critical.

Mitigation factor

The Swekey authentication mechanism must be activated (which is not a requirement in the case of PMASA-2011-5).

Affected Versions

The and earlier versions are affected.

Unaffected Versions

Branch 2.11.x is not affected by this.


Upgrade to phpMyAdmin or or apply the related patch listed below.


This issue was found by Frans Pehrson from Xxor AB.His advisory.

Assigned CVE ids: CVE-2011-2719

CWE ids: CWE-661 CWE-473


The following commits have been made to fix this issue:

The following commits have been made on the 3.3 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is