Change of minimum version requirements


The development team has decided to stop supporting PHP < 4.1.x and MySQL < 3.23.36, starting with phpMyAdmin 2.5.5. This means that
- a warning will be issued on the main phpMyAdmin page if you are running older PHP or MySQL versions
- the .php3 version of the distribution kit will not be available for 2.5.5 and later
- we have added on the Downloads page a link to version 2.2.7pl1, the latest version that was tested against PHP3. Versions after 2.2.7pl1 may or may not work with PHP 3.