If a crafted version.json would be presented, an XSS could be introduced.
Due to not properly validating the version.json file, which is fetched from the phpMyAdmin.net website, could lead to an XSS attack, if a crafted version.json file would be presented.
We consider this vulnerability serious.
This vulnerability can only be exploited with a combination of complicated techniques and tricking the user to visit a page.
Versions 3.5.x (prior to 18.104.22.168) and 4.0.x (prior to 22.214.171.124) are affected.
Upgrade to phpMyAdmin 126.96.36.199 or 188.8.131.52 or newer or apply the patches listed below.
Thanks to Emanuel Bronshtein for reporting these issues.
Assigned CVE ids: CVE-2013-4996
The following commits have been made to fix this issue:
The following commits have been made on the 3.5 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.