Possible session manipulation in Swekey authentication.
It was possible to manipulate the PHP session superglobal using some of the Swekey authentication code. This could open a path for other attacks.
We consider this vulnerability to be critical.
The 3.4.3 and earlier versions are affected.
Branch 2.11.x is not affected by this.
Upgrade to phpMyAdmin 188.8.131.52 or 184.108.40.206 or apply the related patch listed below.
Assigned CVE ids: CVE-2011-2505
The following commits have been made to fix this issue:
The following commits have been made on the 3.3 branch to fix this issue:
For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.